DNS Issues - DDOS attack
Incident Report for Blackbell
Resolved
We have fixed the issue by switching to another DNS routing mechanism. All back to normal!
Posted over 3 years ago. Dec 01, 2014 - 21:59 UTC
Identified
Our DNS provider is experiencing a DDOS attack & as a result we are experiencing technical difficulties. We will update shortly.
Posted over 3 years ago. Dec 01, 2014 - 21:29 UTC