Android Apps Temporary offline
Incident Report for Hotelcloud
Resolved
Resolved 9 days ago... !!
Posted about 1 year ago. Feb 20, 2017 - 20:01 UTC
Identified
We are working on a fix.
Posted about 1 year ago. Feb 10, 2017 - 12:35 UTC